Ticket #2545 (closed feature: fixed)

Opened 7 years ago

Last modified 6 years ago

[UI] ui parameter in callbacks/events should be consistent

Reported by: scott.gonzalez Owned by: scott.gonzalez
Priority: major Milestone: 1.5.2
Component: ui.core Version: 1.5b4
Keywords: ui callback event Cc:
Blocking: Blocked by:

Description

There should be at least some consistency in the ui parameter of callbacks between all plugins.

Change History

comment:1 Changed 7 years ago by rdworth

My feeling is element properties on the ui hash should be DOM Elements. I need to look closer at all plugins' use of ui and see where else consistency might be an issue.

comment:2 Changed 7 years ago by scott.gonzalez

  • Status changed from new to assigned

comment:3 Changed 7 years ago by scott.gonzalez

comment:4 Changed 6 years ago by paul

  • Type changed from bug to feature

Since this is not a bug, I moved it to "feature".

comment:5 Changed 6 years ago by anonymous

  • Milestone 1.2.4 deleted

Milestone 1.2.4 deleted

comment:6 Changed 6 years ago by paul

  • Version changed from 1.2.3 to 1.5b4

comment:7 Changed 6 years ago by paul

  • Status changed from assigned to closed
  • Resolution set to fixed

There is now, because of the widget factory.

comment:8 Changed 6 years ago by paul

  • Milestone set to 1.5.2
Note: See TracTickets for help on using tickets.