Ticket #3232 (closed bug: fixed)

Opened 6 years ago

Last modified 14 months ago

Datepicker Position Problem in IE 6/7

Reported by: roch@… Owned by: grabanski
Priority: major Milestone: 1.7
Component: ui.datepicker Version: 1.6rc2
Keywords: ui datepicker position Cc:
Blocking: Blocked by:

Description

I had a Problem using the ui.datepicker plugin with IE6/7. The Datepicker was shown in the wrong Position.
The browser Width/Height in _checkOffset was 0 for IE.
I tried the Width Detection from:  http://www.mail-archive.com/jquery-en@googlegroups.com/msg13648.html which gives correct Values.

Attachments

ui.datepicker.js.patch Download (1.0 KB) - added by isroch 6 years ago.
Works with this changes

Change History

Changed 6 years ago by isroch

Works with this changes

comment:1 Changed 6 years ago by isroch

I cornered the problem to non strict HTML Pages. strict pages are working fine.

comment:2 Changed 6 years ago by kbwood

  • Status changed from new to closed
  • Resolution set to fixed

Fixed. Added patch.

comment:3 Changed 6 years ago by joern.zaefferer

  • Status changed from closed to reopened
  • Version changed from 1.6b to 1.6rc2
  • Resolution fixed deleted

According to #3603, this issue is still open.

comment:4 Changed 6 years ago by caphun

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed in [1504]

comment:5 Changed 6 years ago by rdworth

  • Status changed from closed to reopened
  • Resolution fixed deleted

If you have an input at the bottom/right/bottom-right of the viewport and you click on it, the datepicker opens below and to the right of it, outside of view. r1504 is a regression. Reopening.

comment:6 Changed 6 years ago by caphun

  • Status changed from reopened to closed
  • Resolution set to fixed

Regression fixed in [1509]

comment:7 follow-up: ↓ 8 Changed 14 months ago by hindpere

In this patch why window.innerWidth is the first choice? It includes the scrollbar width, at least on Chrome 27.0 if there's a scrollbar and the input is at the right then calendar opens behind the browser scrollbar. Cannot show it in jsfiddle because it shows already scrollbar in the result box.

Why not using document.documentElement.clientWidth as the first option and then innerWidth and then clientWidth? Am I missing something?

comment:8 in reply to: ↑ 7 Changed 14 months ago by tj.vantoll

Replying to hindpere:

In this patch why window.innerWidth is the first choice? It includes the scrollbar width, at least on Chrome 27.0 if there's a scrollbar and the input is at the right then calendar opens behind the browser scrollbar. Cannot show it in jsfiddle because it shows already scrollbar in the result box.

Why not using document.documentElement.clientWidth as the first option and then innerWidth and then clientWidth? Am I missing something?

Since this ticket has not been touched in 4 years I don't think anyone would know. If you can still recreate this problem in a test case using the most recent version you can create a new ticket.

That being said we're switching to use the  position utility in the datepicker rewrite, therefore this is unlikely to be changed until the rewrite lands.

Note: See TracTickets for help on using tickets.