Ticket #3488 (closed bug: fixed)

Opened 6 years ago

Last modified 6 years ago

ui.sortable - IE6+ doesn't fire click-event after sorting

Reported by: C-rank Owned by: paul
Priority: critical Milestone: 1.7
Component: ui.sortable Version: 1.6rc2
Keywords: ui, sortable, ie, click, event Cc:
Blocking: Blocked by:

Description

I got a sortable list with e.g. 10 items containing a line of icons (for further actions) and below an image.

Before sorting one of those items the click-event on the images works fine. But after sorting one item, the click-events on the icons of the sorted item, are not firing any more.

Short: Before sorting, clicking the icons of sorted element works fine

After sorting, clicking the icons of sorted element won't work any more.

Works fine in Opera, FF... but NOT in IE6+ Errors in Firebug: None.

See file-attachment for a "working" demo.

Attachments

jquerytest.html Download (2.0 KB) - added by C-rank 6 years ago.
Example to show the Error (open in IE6+)

Change History

Changed 6 years ago by C-rank

Example to show the Error (open in IE6+)

comment:1 Changed 6 years ago by scott.gonzalez

  • Priority changed from major to critical
  • Milestone changed from TBD to 1.6

comment:2 Changed 6 years ago by paul

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r857. Very strange issue, took me hours to debug, it's caused by removing the placeholder in the clear() function (yeah, the placeholder has no relation to the original item at all, weird huh?).

Note: See TracTickets for help on using tickets.