Search and Top Navigation
#3838 closed bug (fixed)
Opened January 15, 2009 10:54PM UTC
Closed January 16, 2009 12:35AM UTC
Last modified October 11, 2012 09:15PM UTC
Components should use this.widgetName on internal methods
Reported by: | eduardo | Owned by: | eduardo |
---|---|---|---|
Priority: | minor | Milestone: | |
Component: | ui.core | Version: | 1.6rc4 |
Keywords: | Cc: | ||
Blocked by: | Blocking: |
Description
We should avoid the usage of "staticNames" on the internal methods of the components.
All instance has a this.widgetName that represents the current name of the component.
For instance:
this.element.removeData("draggable")
should be
this.element.removeData(this.widgetName)