Ticket #3844 (closed bug: fixed)

Opened 6 years ago

Last modified 5 years ago

Accordion icons are not being shown correctly in IE(6)

Reported by: eduardo Owned by:
Priority: blocker Milestone: 1.7
Component: ui.accordion Version: 1.6rc5
Keywords: Cc:
Blocking: Blocked by:

Description (last modified by rdworth) (diff)

In the default accordion in IE6, the icons display way below the accordion. This is not a demos issue, as it can be seen on an individual static and visual test pages

 http://jquery-ui.googlecode.com/svn/trunk/tests/static/accordion.html

 http://jquery-ui.googlecode.com/svn/trunk/tests/visual/accordion.html

Change History

comment:1 Changed 6 years ago by eduardo

  • Component changed from ui.core to ui.accordion

comment:2 Changed 6 years ago by scott.gonzalez

  • Priority changed from blocker to critical
  • Milestone changed from TBD to 1.6

comment:3 Changed 6 years ago by paul

  • Component changed from ui.accordion to [meta] demos
  • Summary changed from Accordion icons are not being shown on IE7 to Accordion icons are not being shown on IE7 on demos/index.html

Not a bug in in Accordion, but in the demos/index.html.

comment:4 Changed 6 years ago by rdworth

  • Priority changed from critical to blocker
  • Component changed from [meta] demos to ui.accordion
  • Description modified (diff)
  • Summary changed from Accordion icons are not being shown on IE7 on demos/index.html to Accordion icons are not being shown correctly in IE(6)

comment:5 Changed 6 years ago by joern.zaefferer

The culprit is this definition in ui.accordion.css:

.ui-accordion .ui-icon { position: absolute; left: .5em; top: 50%; margin-top: -8px; }

More specifically, the top: 50% throws IE off, for whatever reason. Not sure yet how to workaround that.

comment:6 Changed 6 years ago by joern.zaefferer

  • Status changed from new to closed
  • Resolution set to fixed

Replacing top: 50% with top: 1.15em seems to fix the issue in IE6 while keeping other browsers intact as well.

Fixed in r1724.

comment:7 follow-up: ↓ 8 Changed 6 years ago by bohdan.ganicky

I modified the fix. The issue is that IE6 is able to position to a parent with triggered hasLayout only. You can trigger the hasLayout with simply defining height: 1% or zoom: 1 for IE6 only.

comment:8 in reply to: ↑ 7 Changed 6 years ago by bohdan.ganicky

Modified fix in r1725.

Note: See TracTickets for help on using tickets.