Ticket #3883 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

accordion: fillSpace demo broken in IE6

Reported by: rdworth Owned by:
Priority: blocker Milestone: 1.7
Component: ui.accordion Version: 1.6rc5
Keywords: Cc:
Blocking: Blocked by:

Description

If you view the accordion fillSpace demo in IE6

 http://jquery-ui.googlecode.com/svn/tags/1.6rc5/demos/accordion/fillspace.html

you'll see two issues

  1. it starts much too tall
  2. when you resize to make it smaller, it gets bigger

Change History

comment:1 Changed 5 years ago by joern.zaefferer

At first I suspected some correlation with the resizable - but disabling it yields exactly the same result. The code calculating the height to fill must be bogus in IE.

comment:2 Changed 5 years ago by joern.zaefferer

The issue occurs in IE7 too, but only in quirks mode. That's the case when opening demos/index.html without being processed by PHP, as the response contains this in the first line: <?php if(!isset($plain)) { ?>

Removing that fixes the issue in IE7, as the correct doctype is then applied. Doesn't help IE6, though the issue is probably very similar.

comment:3 Changed 5 years ago by paul

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r1809.

Note: See TracTickets for help on using tickets.