Ticket #4182 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

slider min/max classes aren't being added to range div

Reported by: scottjehl Owned by: rdworth
Priority: critical Milestone: 1.7
Component: ui.slider Version: 1.6rc6
Keywords: Cc:
Blocking: Blocked by:

Description (last modified by scottjehl) (diff)

the ui-slider-range-max class is not being added to the ui-slider-range div. Same for the ui-slider-range-min class. Instead, the styles are being set inline. Only the styles that need computing based on value should be set inline.

The CSS is already designed to support these classes.

Change History

comment:1 Changed 5 years ago by scottjehl

  • Owner set to rdworth
  • Status changed from new to assigned

comment:2 Changed 5 years ago by scottjehl

  • Priority changed from major to critical
  • Description modified (diff)

This is actually the cause of the Opera bug too. From my testing, it appears the change discussed a while back where we'd remove the unnecessary value in min and max has not been implemented.

For example, in a horizontal slider max range, the left value should never be set inline. Only a width - nothing else. The css already has right: 0.

This should be true of all slider min/max ranges, respectively. I closed bug 3850 and assigned this to rdworth.

comment:3 Changed 5 years ago by scottjehl

Note that our static demo pages for min and max have this class and inline css properly applied. trunk/tests/static/slider/slider_horizontal_range_max.html trunk/tests/static/slider/slider_horizontal_range_min.html

same for vertical

comment:4 Changed 5 years ago by rdworth

  • Milestone changed from TBD to 1.6

comment:5 Changed 5 years ago by rdworth

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed in r2118.

Note: See TracTickets for help on using tickets.