Ticket #4606 (closed feature: wontfix)

Opened 5 years ago

Last modified 17 months ago

Dialog: dialog('disable') does not disable OK/Cancel buttons inside dialog

Reported by: BegemoT Owned by:
Priority: major Milestone: 1.10.0
Component: ui.dialog Version: 1.7.2
Keywords: redesign Cc:
Blocking: Blocked by:

Description

Let me have a dialog with some form inside it, and Save/Cancel buttons. When user press Save I send form data to server via ajax. To prevent user from doing any movements while bytes are running back and forth I disable dialog ( dlg.dialog('disable') ). But this disabling only inputs in my form, not Save/Cancel buttons! I expect them to be disabled too.

Change History

comment:1 Changed 5 years ago by joern.zaefferer

  • Type changed from bug to enhancement
  • Milestone changed from TBD to 1.8

comment:2 Changed 4 years ago by scott.gonzalez

comment:3 Changed 3 years ago by scott.gonzalez

  • Keywords redesign added
  • Type changed from enhancement to feature

comment:4 Changed 19 months ago by scott.gonzalez

#8610 is a duplicate of this ticket.

comment:5 Changed 19 months ago by paladin4ik

Note that this is not happening only when opening a new dialog but even When calling the disable method of the dialog it only change the UI to semi-transparent. this is not what would be expected from the "Disable" method.

Possible workaround\ solution: Then I did the following workaround:  http://jsfiddle.net/andrewwhitaker/p7tV7/15/

comment:6 Changed 19 months ago by scott.gonzalez

  • Milestone changed from 1.9.0 to 1.10.0

comment:7 Changed 18 months ago by fontzter

Some questions related to disabled buttons:

1) If you disable buttons with the dialog this will lock the entire UI if the dialog is modal. Is this desirable?

2) What about the close icon in the header?

3) What about the header itself?...Should the dialog remain draggable in a disabled state?

comment:8 Changed 18 months ago by petersendidit

  • Status changed from new to open
  • Summary changed from dialog('disable') does not disable OK/Cancel buttons inside dialog to Dialog: dialog('disable') does not disable OK/Cancel buttons inside dialog

comment:9 Changed 18 months ago by bchiasson

  • Owner set to bchiasson
  • Status changed from open to assigned

comment:10 Changed 18 months ago by bchiasson

  • Owner bchiasson deleted
  • Status changed from assigned to open

comment:11 Changed 17 months ago by scott.gonzalez

  • Status changed from open to closed
  • Resolution set to wontfix

Disabling dialogs doesn't really make sense. You can easily disable the individual buttons if you want. I'm inclined to actually remove the disabled option from dialog.

Note: See TracTickets for help on using tickets.