Ticket #4641 (closed bug: wontfix)

Opened 5 years ago

Last modified 18 months ago

Datepicker doesn't take the yearRange into account when rendering

Reported by: afx Owned by:
Priority: minor Milestone:
Component: ui.datepicker Version: 1.7.2
Keywords: datepicker, yearRange, current year, _selectDay Cc:
Blocking: Blocked by:

Description

When using the option yearRange: 2010-2011 the datepicker renders the _selectDay function with the current year

<td class="" onclick="DP_jQuery.datepicker._selectDay('#date_field ',26,2009, this);return false;">

Change History

comment:1 Changed 5 years ago by kbwood

  • Status changed from new to closed
  • Resolution set to wontfix

The yearRange setting just restricts the years that appear in the drop-down list. If you only want people to select dates within these years, you must use the minDate and maxDate settings.

comment:2 Changed 18 months ago by scott.gonzalez

  • Milestone TBD deleted

Milestone TBD deleted

comment:18 Changed 18 months ago by mikesherov

#7782 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.