Ticket #4751 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

Dragging slider modifies values, even if callback returns false

Reported by: bkrausz Owned by:
Priority: minor Milestone: 1.8
Component: ui.slider Version: 1.7.2
Keywords: Cc:
Blocking: Blocked by:

Description

Line 347 of ui.slider.js:

                var newValues = this.values();
                newValues[index] = newVal;

actually modifies the value. This causes two problems:

1) One can't determine the old value inside the slide callbacks (for example, to determine if the slider is being dragged to the left or right).

2) Possibly the cause of bug #4385, since the value will be changed, and all further requests will be fail because of this.

Should probably change this to:

                var newValues = this.values().clone();
                newValues[index] = newVal;

Change History

comment:1 Changed 5 years ago by scott.gonzalez

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone changed from TBD to 1.8

Fixed in r3027. Thanks.

Note: See TracTickets for help on using tickets.