Ticket #4758 (closed bug: notabug)

Opened 5 years ago

Last modified 3 years ago

Modal dialog in IE8 causes endless event-loop

Reported by: Wixbit Owned by: Wixbit
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.7.2
Keywords: Cc:
Blocking: Blocked by:

Description

Loading the following page in IE8 and pressing the 'Open Dialog' button will cause an endless resize-event loop.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
	<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
	<title>Default Title</title>
	
	<!-- JavaScripts -->
	<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.js"></script>
	<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.7.1/jquery-ui.js"></script>
	
	<!-- StyleSheets -->
	<link rel="stylesheet" type="text/css" href="http://ajax.googleapis.com/ajax/libs/jqueryui/1.7.1/themes/smoothness/jquery-ui.css" />
</head>
<body>

<div id="jqd" title="Test!">
	<textarea name="test"></textarea>
</div>

<input type="button" value="Open Dialog" onclick="$('#jqd').dialog({ modal: true, width: 'auto' });" />

</body>
</html>

After loading the page and pressing the button, add a breakpoint to line 7724 in jquery-ui.js (first line in the resize event handler for dialogs) and you will see this point is hit without end.

Change History

comment:1 Changed 5 years ago by BalusC

The infinite loop will be stopped if you outcomment line 7644: $(window).bind('resize.dialog-overlay', $.ui.dialog.overlay.resize);

This information may help further in fixing the bug.

Cheers, B

comment:3 Changed 5 years ago by scott.gonzalez

  • Milestone changed from TBD to 1.8

comment:4 Changed 4 years ago by scott.gonzalez

  • Status changed from new to closed
  • Resolution set to worksforme

I can't reproduce this.

comment:5 Changed 4 years ago by sbassin

  • Status changed from closed to reopened
  • Resolution worksforme deleted

For what it's worth, I was having the same endless event-loop issue in both jQuery-UI 1.8.1 and 1.8.6 in IE8 and commenting out the above line stopped said loop.

comment:6 Changed 3 years ago by scott.gonzalez

  • Owner set to Wixbit
  • Status changed from reopened to pending

Please provide a reduced test case showing the problem.

comment:7 Changed 3 years ago by trac-o-bot

  • Status changed from pending to closed
  • Resolution set to invalid

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.