Ticket #4869 (closed bug: fixed)

Opened 5 years ago

Last modified 4 years ago

Datepicker undesired today date on field & appendText

Reported by: Miroku_87 Owned by:
Priority: minor Milestone: 1.8
Component: ui.datepicker Version: 1.7.2
Keywords: option field value Cc:
Blocking: Blocked by:

Description

Hi everyone, I found a bug. Watch here:  http://jsbin.com/efuxe

In the input fields I put the value attribute to "tryout" but when the page is loaded instead of tryout we find the current date. Moreover, appendText doesn't work. I found out that the problem is the option setting after initialization.

In fact, this page works:  http://jsbin.com/enani/edit

Change History

comment:1 Changed 4 years ago by joern.zaefferer

  • Priority changed from major to minor
  • Milestone changed from TBD to 1.8

comment:2 Changed 4 years ago by kbwood

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r3670. The value 'tryout' is deleted due to an attempt to retain an existing date in the (possibly) new format when changing options, since it is not a valid date.

Note: See TracTickets for help on using tickets.