Ticket #5563 (closed bug: fixed)

Opened 4 years ago

Last modified 3 years ago

Draggable connected to Sortable, [AJAX (Draggable) + WIDE SELECT] in same table cell. Drop fails.

Reported by: Niloct Owned by:
Priority: major Milestone: 1.8.11
Component: ui.sortable Version: 1.8
Keywords: Cc:
Blocking: Blocked by:

Description

The attached files provide all source code needed to reproduce odd behavior in the subject.

I have AJAX loading a chunk of HTML which contains a draggable. The _placeholder_ of this chunk is inside a table cell, together with a SELECT box (right above the placeholder).

AFTER I load the AJAX, the following occurs:

goodSortable.html - I am able to drag the cross and drop it inside the dropspot, without any hacks.

badSortable.html - Only after I "disturb" the dropspot, by dragging _the dropspot_ and dropping it somewhere, then the drag & drop with the cross works.

Things to consider:

A) If the chunk in statically embedded in the DIV placeholder (i.e. no AJAX), it works on badSortable.html

B) Also, in goodSortable.html, if you set the SELECT width to something too large, it will break.

Conclusion:

There must not be a SELECT on the same cell that the placeholder of AJAX, which would EXPAND the loaded DIV more than it's ORIGINAL WIDTH.

If this condition happens, there's no drop in dropsort without the hack described above.

Attachments

sortable_AJAX.zip Download (81.9 KB) - added by Niloct 4 years ago.

Change History

Changed 4 years ago by Niloct

comment:1 Changed 4 years ago by Niloct

UPDATE: Problems with IE (who hasn't ?)

I tested goodSortable.html _only_ in Chrome and Firefox under Linux/Win7.

For IE, the suggested workaround doesn't work (i.e. narrowing the select).

For IE8 only, hovering the dropspot once, hovering out, and over again activates the dropspot. No need for "disturbing" the dropspot first but alas it's not a clean solution.

comment:2 Changed 4 years ago by scott.gonzalez

  • Priority changed from critical to major

comment:3 Changed 4 years ago by scott.gonzalez

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone changed from TBD to 1.8.11

comment:4 Changed 3 years ago by rdworth

#6261 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.