Ticket #5567 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

button text, hide then show again

Reported by: jwystup Owned by:
Priority: minor Milestone: 1.8.2
Component: ui.button Version: 1.8
Keywords: button, text Cc:
Blocking: Blocked by:

Description

I'm trying to create a toolbar that displays text and icons on buttons. But when the browser is resized to smaller than the width of the toolbar with all of the text (before it wraps to a new line of buttons), I want to remove the text. This works fine. The problem is when I try to add the text back in (when the window is big enough to show it again). The icons are shifted to the left, but no text. Maybe I'm doing something wrong. Here's the problem code:

/* on resize function */
function updateToolbar() {
	/* Update Width: */
	if (jq(".toolbar").innerWidth() > 710) { //text
		jq(".toolbar button").button("option", "text", true);
	} else { //just icons
		jq(".toolbar button").button("option", "text", false);
	}
}

Change History

comment:1 Changed 5 years ago by scott.gonzalez

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone changed from TBD to 1.9

Fixed in  01ad6ce.

comment:2 Changed 5 years ago by rdworth

  • Milestone changed from 1.9 to 1.8.2
Note: See TracTickets for help on using tickets.