Ticket #5857 (closed bug: duplicate)

Opened 4 years ago

Last modified 3 years ago

Tabs should use context when searching for panels

Reported by: petersendidit Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.tabs Version: 1.8.2
Keywords: Cc:
Blocking: Blocked by:

Description

If a tabs href is a valid hash then tries to push that panel in to the panels array. This works great if the tabs are already in the document but if they are in a documentFragment then this fails.

The fix is easy. Just change this line in the _tabify function

self.panels = self.panels.add(self._sanitizeSelector(href));

to

self.panels = self.panels.add(self._sanitizeSelector(href), self.element);

Now it will handle the tabs not being part of the document yet.

Change History

comment:2 Changed 4 years ago by scott.gonzalez

  • Keywords tabs removed
  • Component changed from ui.core to ui.tabs

comment:3 Changed 4 years ago by waldmang

Same apply also to the $show element: $show = $(self._sanitizeSelector(this.hash));

should be

$show = $(self._sanitizeSelector(this.hash),self.element);

comment:4 Changed 3 years ago by scott.gonzalez

  • Status changed from new to closed
  • Resolution set to duplicate

comment:5 Changed 3 years ago by scott.gonzalez

Duplicate of #6710.

Note: See TracTickets for help on using tickets.