Ticket #5890 (closed bug: duplicate)

Opened 4 years ago

Last modified 22 months ago

Sortable:sortout fires on sortstart and sortstop too

Reported by: Peter007 Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.8.2
Keywords: Cc:
Blocking: Blocked by:

Description

Working example  http://jsfiddle.net/FrbW8/22/

Can your fix this bug?

Thanx for help.

Kind regards Peter (germany)

Change History

comment:1 Changed 2 years ago by scott.gonzalez

  • Milestone changed from TBD to 2.0.0

comment:2 Changed 2 years ago by petersendidit

  • Status changed from new to open
  • Summary changed from SortOut: fires on sortstart and sortstop too to Sortable:sortout fires on sortstart and sortstop too

The docs say that the out event is triggered when a sortable item is moved away from a connected list. Yet it its firing even when the sortable doesn't have a connected list. Which is right the code or the docs?

comment:3 Changed 22 months ago by tj.vantoll

  • Status changed from open to closed
  • Resolution set to duplicate

Duplicate of #8669.
I'm not seeing the out fired on start, and the firing on stop is intended and has since been documented as such (see #8669).

See petersendidit's comments I will change the API documentation to remove the word "connected" from the out and over events since they occur on all sortable lists.

Note: See TracTickets for help on using tickets.