Ticket #6218 (closed bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

Autocomplete with scroll behaves incorrectly with combination of mouse and keyboard user input

Reported by: yeoldeape Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.autocomplete Version: 1.8.5
Keywords: UI Autocomplete Mouse Keyboard Scroll Cc:
Blocking: Blocked by:

Description

Hi everybody,

This behavior can be seen on the demo posted on the jquery UI site:  http://jqueryui.com/demos/autocomplete/#maxheight

If the user mouses over one of the items and leaves it there, and then subsequently uses the keyboard to scroll down, the presence of the mouse seems to be firing an event which causes the selection to be higher in the list than expected.

This is also the case if the mouse happens to be positioned underneath the input box (where the autocomplete UL will be placed) before any input is actually entered (which can happen randomly even if the user is using only the keyboard). So it's really a critical issue for the "scrollable results" application, though of course that's only one application of the UI autocomplete element.

This behavior is seen using Safari Version 5.0.1 (5533.17.8) and Firefox/3.5.11 on Mac OS X 10.5.

Thanks, Greg

Change History

comment:1 Changed 3 years ago by scott.gonzalez

  • Priority changed from critical to minor
  • Milestone changed from TBD to 1.9

This is not critical, even for scrollable results. It's wrong and annoying, but doesn't prevent the use of the plugin at all. I'm also not sure that this can be cleanly fixed, since the browser is sending mouse events on scroll.

comment:2 Changed 3 years ago by lex1982

comment:3 Changed 3 years ago by scott.gonzalez

  • Status changed from new to closed
  • Resolution set to duplicate

Closing as duplicate of a newer ticket because the newer ticket is more general and suggests a solution.

comment:4 Changed 3 years ago by scott.gonzalez

Duplicate of #7024.

Note: See TracTickets for help on using tickets.