Ticket #6949 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Datepicker: Rendering problem after changing numberOfMonths option

Reported by: KrishnarajD Owned by:
Priority: minor Milestone: 1.8.13
Component: ui.datepicker Version: 1.8.6
Keywords: Cc:
Blocking: Blocked by:

Description

When i try to set the datepicker's "numberOfMonths" value to 2 at runtime, the datepicker alignment was not proper.

//Checked by using the below code snippet.
$( "#datepicker" ).datepicker( "option", "numberOfMonths", 2 );

Checked in the below link using Firebug tool.
 http://jqueryui.com/demos/datepicker/#multiple-calendars

Change History

comment:1 Changed 3 years ago by scott.gonzalez

  • Status changed from new to open
  • Component changed from ui.core to ui.datepicker

comment:2 Changed 3 years ago by kzys

What is your browser? I can't reproduce alignment problem with Firefox 4 and Safari 5. My test code is below.

        $( "#datepicker" ).datepicker({
            numberOfMonths: 2,
            showButtonPanel: true
        });

comment:3 Changed 3 years ago by scott.gonzalez

@kzys: The problem is with $( "#datepicker" ).datepicker( "option", "numberOfMonths", 2 ) after initialization.

comment:4 Changed 3 years ago by scott.gonzalez

  • Status changed from open to closed
  • Resolution set to fixed
  • Milestone changed from 1.9 to 1.8.13

comment:5 Changed 3 years ago by scott.gonzalez

  • Summary changed from Datepicker-Issue with "numberOfMonths" option to Datepicker: Rendering problem after changing numberOfMonths option
Note: See TracTickets for help on using tickets.