Ticket #7266 (closed bug: duplicate)

Opened 3 years ago

Last modified 18 months ago

datepicker taborder - focus problem internet explorer

Reported by: lankarden Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.8.9
Keywords: Cc:
Blocking: Blocked by:

Description

I've got a test case in jsFiddle to show the problem:  http://jsfiddle.net/lankarden/9FtnW/

A default datepicker will break the taborder when the date is selected via the popup, in the test case, hitting the tab key after selecting the date with the mouse, will result in the first field of the form getting the focus.

I found a fix for this problem, but it creates another one: after selecting the date via the popup with the mouse, internet explorer (I use IE8, but i think the problem occurs in all versions) presents the popup again.

Change History

comment:1 Changed 3 years ago by cmoschini

This also occurs in Chrome 10/Windows and FF3.5/Windows - I suspect this bug is not browser-specific and instead just a general bug in the code.

comment:2 Changed 3 years ago by fracmak

There's an if statement in there preventing the focus from being reestablished, probably to fix the issue you're describing with IE. There's a weird hack in the code to prevent the dialog from reappearing when a focus event happens and they don't mean it to trigger the dialog, except it fails in IE because IE queues up the focus event until after the current execution is done, so the hack doesn't work. Again, the current broken if statement is bypassing it. This essentually is a chicken and an egg problem which requires more thought before a solution is provided.

comment:3 Changed 22 months ago by scott.gonzalez

  • Milestone changed from 1.9.0 to 1.11.0

comment:4 Changed 21 months ago by mikesherov

  • Status changed from new to open

comment:5 Changed 18 months ago by tj.vantoll

  • Status changed from open to closed
  • Resolution set to duplicate

Duplicate of #7765.
The core issue here is that focus is not being placed back in the input.

Note: See TracTickets for help on using tickets.