Ticket #7437 (closed feature: duplicate)

Opened 3 years ago

Last modified 19 months ago

Datepicker: Norwegian i18n file(s)

Reported by: bjornjohansen Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.8.13
Keywords: Cc:
Blocking: Blocked by:

Description

Norwegian really isn't language used in writing. Instead there are two different languages used: Norwegian Bokmål (nb) and Norwegian Nynorsk (nn).

The current datepicker i18n file jquery.ui.datepicker-no.js really is Norwegian Bokmål (nb) and should be renamed accordingly (to jquery.ui.datepicker-nb.js). The instances of $.datepicker.regional['no'] should also be renamed $.datepicker.regional['nb'], of course.

This would help a lot when loading the files automaticly based on page locale (nb_NO).

This file could also be copied to jquery.ui.datepicker-nn.js and would be correct with the following replacement: weekHeader: 'Veke',

Leaving the old file will do no harm, and take care of backwards compability. Perhaps with a note to use nb/nn instead?

Change History

comment:1 Changed 3 years ago by bjornjohansen

Just discovered that the Norwegian Nynorsk file also needs these translations:
dayNamesShort: ['sun','mån','tys','ons','tor','fre','lau'],
dayNames: ['sundag','måndag','tysdag','onsdag','torsdag','fredag','laurdag'],
dayNamesMin: ['su','ma','ty','on','to','fr','la'],

comment:2 Changed 2 years ago by scott.gonzalez

  • Type changed from enhancement to feature

comment:3 Changed 23 months ago by scott.gonzalez

  • Milestone changed from 1.9.0 to 1.11.0

comment:4 Changed 23 months ago by petersendidit

  • Status changed from new to open
  • Summary changed from Norwegian i18n file(s) to Datepicker: Norwegian i18n file(s)

comment:5 Changed 19 months ago by scott.gonzalez

  • Status changed from open to closed
  • Resolution set to duplicate

Duplicate of #8886.

Note: See TracTickets for help on using tickets.