Ticket #7666 (closed bug: duplicate)

Opened 3 years ago

Last modified 2 years ago

Memory leakage with jQuery 1.6 and jQuery 1.8.16 on IE 7?

Reported by: liminzhang Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.core Version: 1.8.16
Keywords: Cc:
Blocking: Blocked by:

Description

Hi there,

I tested two blank pages on IE7

The first page

<head>

<script src="/jquery/1.6.2/jquery.min.js" type="text/javascript"></script> <script src="/jqueryui/1.8.16/jquery-ui.min.js" type="text/javascript"></script>

</head> <body> </body>

The second page

<head>

<script src="/jquery/1.4.2/jquery.min.js" type="text/javascript"></script> <script src="/jqueryui/1.8.16/jquery-ui.min.js" type="text/javascript"></script>

</head> <body> </body>

After each refreshing with F5, IExplore used 2 or 3 more megabytes memory with the first page. However it did not happen on the second page.

Does jQuery 1.6.2 bring memory leakage for jQuery UI library? It also happens on jQuery 1.5.1, 1.6.1.

Thanks

Limin

Change History

comment:1 in reply to: ↑ description Changed 3 years ago by peter.nystrom

After doing some tests, it seems that the memory leak started in jQuery UI 1.8.13. By reverting the changes in #7256, the memory leak disappears. The tests were done with jQuery 1.6.2. Can someone verify?

/Peter

Last edited 3 years ago by peter.nystrom (previous) (diff)

comment:2 Changed 3 years ago by gornale

Hello, sorry for bad english.

I am in the same configuration ui 1.8.16 , Jquery 1.6.2 and IE7 . And have the same huge memory leak . (I try with 1.8.x too)

4 MO !!!! at each refresh, with just adding reference to Jquery and UI script on my page!!!! i do nothing else!!!

Jquery UI is so wonderful ...

No idea why, but IF YOU WANT IT TO WORK follow these steps.

Download (with the custom download ) only the package that you need (I download only Dialog) and it works ! no memory leak.!

I test a little and the memory leak seems to appear when i have integrated the DatePicker (even if i don't use it! just refreshed my page).

Now, i can use the Dialog (seems to be ok for the rest but don't download the datePicker). I will try futher later to isolate the datePicker.

I hope that a developper will read my post to kill this ugly bug.

Bye

Last edited 3 years ago by gornale (previous) (diff)

comment:3 Changed 3 years ago by minni

I can confirm that the memory leak in IE7 is gone if jquery-ui lib is used without datepicker. (Versions: jquery-ui 1.8.16, jquery 1.6.3)

Thanks Limin for your report, that helped me a lot! :) And many thanks to gornale for the fix!

Yours, Minni

Last edited 3 years ago by minni (previous) (diff)

comment:4 in reply to: ↑ description Changed 3 years ago by magonye

Hi,

I have the same problem. IE7 with memory leaks, after each refresh with F5.

The solution of excluding the datepicker from the UI is not working for me.

I've just test with jquery 1.6.1, 1.6.3 and 1.6.4 and with jquery-UI 1.8.13 & jquery-UI 1.8.16.

In my tests, the only way to avoid the memory leak is do not to include jquery-UI in the page.

Anyone can help?

Thanks.

Mike.

comment:5 Changed 3 years ago by zack9433

Hello,

I test this issue using jQuery 1.7.1 and jQuery-UI 1.8.17. The DatePicker still causes memory leak about 2MB in my situation.

Anyone have idea to deal with this issue? thx.

Zack

Last edited 3 years ago by zack9433 (previous) (diff)

comment:6 Changed 2 years ago by goran

Hello!

I have done a test with jQuery 1.7.1 and jQuery-UI 1.8.17.
From jQuery-UI 1.8.17 I have reverted the change #7256 that Peter talks about in the first comment above. In this setup there seems to be NO memory leak at all in IE7.
The change in #7256 is to bind hover events (mouseout and mouseover) with 'delegate' instead of 'bind' on the Datepicker component. Also a global variable 'instActive' is added which is used in the 'delegate'.
Can the change from 'bind' to 'delegate' be the reason for the memory leak or can the global variable cause the trouble in some way?

A Penny For Your Thoughts.

/Göran :-)

comment:7 Changed 2 years ago by scott.gonzalez

  • Status changed from new to closed
  • Resolution set to duplicate

comment:8 Changed 2 years ago by scott.gonzalez

Duplicate of #4188.

Note: See TracTickets for help on using tickets.