Ticket #7857 (closed bug: notabug)

Opened 3 years ago

Last modified 2 years ago

Popup: accessibility

Reported by: ezufelt Owned by:
Priority: minor Milestone: 1.9.0
Component: [meta] ui.dev Version: git
Keywords: a11y Cc:
Blocking: Blocked by:

Description

Firefox 7.0.1 + JAWS 13 and NVDA 2011.1.1 Safari 5.0.5 + VoiceOver (SL)

When the default popup opens focus is set to the username field, but the 'dialog' role and 'Login options' aria-label are not announced. Reports that this is working correctly in NVDA 2011.1.1 + Firefox 10pre

Popup on Hover

Not accessible from keyboard or with screen-readers. No control exposed to trigger popup.

Change History

comment:1 Changed 3 years ago by ezufelt

Confirmed that in Firefox 8 + JAWS 13 and NVDA 2011.1.1 that "Dialog Login options" is read when dialog appears and focus is set.

Also notice that nothing is announced when dialog disappears (may happen by clicking on a control outside of the dialog, or pressing <esc>.

comment:2 Changed 3 years ago by scott.gonzalez

  • Keywords a11y added
  • Status changed from new to open
  • Component changed from ui.core to [meta] ui.dev

comment:3 Changed 2 years ago by scott.gonzalez

  • Status changed from open to closed
  • Resolution set to invalid

Closing since we deprioritized popup (and we don't use Trac for unreleased plugins).

Note: See TracTickets for help on using tickets.