Ticket #7931 (closed bug: fixed)

Opened 2 years ago

Last modified 2 years ago

Documentation for jquery.ui.tabs remove method is incomplete

Reported by: bmonty Owned by:
Priority: minor Milestone: 1.8.18
Component: ui.tabs Version: 1.8.16
Keywords: Cc:
Blocking: Blocked by:

Description

This is not a bug with the remove() method like I originally thought. However, the documentation could be clearer about how the method can be used.

Specifically, the index parameter on the remove method can refer to either an index (integer) or a tab's href (string) in order to attain the index of the tab the user is looking for. Using index by passing an integer can be a little deceiving because the index required is the index as it was when the tab was originally added. This means that if you are using sortable() on the tabs, the integer-based index becomes a little difficult to use. Once I switched to using the href (string-based index) instead, this became much easier to use to find the tab I wanted.

I tried looking around the GitHub repos, but I couldn't find a spot where I could submit a patch for a documentation update. Can someone point me to how I can do that so I can contribute? Thanks.

Change History

comment:1 Changed 2 years ago by scott.gonzalez

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone changed from 1.9 to 1.8.18

Fixed on docs.jquery.com.

Note: See TracTickets for help on using tickets.