Ticket #7944 (closed bug: fixed)

Opened 2 years ago

Last modified 23 months ago

Slider: IE6-8 cannot animate slider handle between 0% and 100%

Reported by: taitems Owned by:
Priority: minor Milestone: 1.8.16
Component: ui.slider Version: 1.8.16
Keywords: Cc:
Blocking: Blocked by:

Description

It's frustratingly easy to cause a JS error when attempting to toggle the slider value between 0-100. Only occurs in IE versions 6, 7 and 8. Has to do with jQuery UI attempting to animate to a NaN value (auto, I assume?) and jQuery core cracking the sads.

To replicate:  http://jsfiddle.net/uGNkC/2/

Change History

comment:1 Changed 2 years ago by taitems

Also, this is related to the core jQuery bug:  http://bugs.jquery.com/ticket/10669

comment:2 Changed 2 years ago by scott.gonzalez

  • Status changed from new to open

comment:3 Changed 2 years ago by taitems

It is most likely caused by that bug, but I wanted to create a bug here so we have a paper trail of what is broken as a result. I put a hotfix in from another bug that prevents the error, but it no longer animates in IE6-8 and just jumps directly to 0.

comment:4 Changed 23 months ago by mikesherov

This bug, and the core bug it stems from  http://bugs.jquery.com/ticket/8158, look fixed to me, can anyone confirm?

comment:5 Changed 23 months ago by mikesherov

This is fixed in core.

comment:6 Changed 23 months ago by scott.gonzalez

  • Status changed from open to closed
  • Resolution set to fixed
  • Milestone changed from 1.9 to 1.8.16
Note: See TracTickets for help on using tickets.