Ticket #8011 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Datepicker: Dialog not closing on second trigger if opened using image

Reported by: mereth Owned by:
Priority: minor Milestone: 1.8.18
Component: ui.datepicker Version: 1.8.17
Keywords: Cc:
Blocking: Blocked by:

Description

I have two datepicker on the same page and both are their own trigger.

If i click on the first trigger, the datepicker popup, then i click directly on the second trigger, the first dialog is closed and the new dialog is opened at the right place, but i can't close this dialog by clicking out of it or selecting a date, i have to reopen the first one with the first trigger.

I reproduce this behavior under ie8/i8-compatibilymode/firefox9 with jquery ui 1.8.17. Reverting to jquery ui 1.8.16 fix this issue.

 http://jsfiddle.net/bN5EU/ (working test case, jsfiddle use 1.8.16 atm)

Regards

Change History

comment:1 Changed 3 years ago by mereth

Forgot to say i use jquery 1.7.1

comment:2 Changed 3 years ago by scott.gonzalez

  • Status changed from new to closed
  • Resolution set to invalid

You can't have two fields with the same id; that's invalid HTML.

comment:3 Changed 3 years ago by mereth

Sorry but it was just a copy/paste typo in jsfiddle, btw it can't be reproduce in it because it use jquery-ui 1.8.16 where this issue doesn't occur.

You can find a new test case with both working (1.8.16) and not (1.8.17) scenarii here :  http://dl.free.fr/vlIRYhmyO

Regards

ps: I can't reopen the issue, i hope this will not fall in the abyss of the internet :)

comment:4 Changed 3 years ago by scott.gonzalez

It works perfectly fine for me with 1.8.17:  http://jsfiddle.net/bN5EU/1/

comment:5 Changed 3 years ago by mereth

I hope this video will help you to see the difficulties i have to close the second datepicker dialog.

 http://youtu.be/-5yXy4fhu9I

comment:6 Changed 3 years ago by scott.gonzalez

  • Status changed from closed to reopened
  • Resolution invalid deleted
  • Summary changed from dialog not closing on second trigger to Datepicker: Dialog not closing on second trigger if opened using image

This issue only occurs if you open the second datepicker using the image while the first datepicker is open.

comment:7 Changed 3 years ago by scott.gonzalez

  • Status changed from reopened to open

comment:8 Changed 3 years ago by scott.gonzalez

  • Status changed from open to closed
  • Resolution set to fixed
  • Milestone changed from 1.9 to 1.8.18

Fixed with #5818.

comment:9 Changed 3 years ago by mereth

Thanks

comment:10 Changed 3 years ago by scott.gonzalez

#8059 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.