Ticket #8633 (closed bug: wontfix)

Opened 2 years ago

Last modified 2 years ago

IE10 issue

Reported by: mazzoo Owned by: mazzoo
Priority: minor Milestone: 1.9.1
Component: ui.sortable Version: 1.8.24
Keywords: Cc:
Blocking: Blocked by:

Description

When using IE10, and scrolling Down a bit on your demosite (  http://jqueryui.com/demos/sortable/ ) The entire sorting does not Work, it scrolls / jumps the page and does not look right. It looks like the old FF error.

Change History

comment:1 Changed 2 years ago by scott.gonzalez

  • Owner set to mazzoo
  • Status changed from new to pending

I'm not seeing any problems on the old or new site. Are you still seeing problems with 1.9.0?

comment:2 Changed 2 years ago by mazzoo

  • Status changed from pending to new

I am running Windows 8. Don't know if it has anything to do with that ? On the new site, it doesn't jump. But it doesn't work either. It looks like there is an offset, when I scroll Down on the page.

comment:3 Changed 2 years ago by scott.gonzalez

The machine I tested on was Windows 8 as well. I've asked someone else to test as well to see if they can reproduce this.

comment:4 Changed 2 years ago by scott.gonzalez

  • Status changed from new to pending

Can you confirm whether you're talking about sortable not working on touch screens or whether you're talking about a bug specific to the page being scrolled? So far nobody has been able to reproduce a problem with the page scrolled while using a mouse.

comment:5 Changed 2 years ago by scott.gonzalez

Also, can you confirm that you're using a stable release of IE10 and not a pre-release?

comment:6 Changed 2 years ago by mazzoo

  • Status changed from pending to new

I am using a mouse and the final release of both Windows 8 and IE10. I have recorded this video to show the problem.  http://tinypic.com/r/2vnnix2/6

comment:7 Changed 2 years ago by scott.gonzalez

It's quite strange that nobody else has reproduced this yet. Do you have access to any other IE10 machines to test on? Do you have any browser plugins installed? I'll leave this open for now, but until we can reproduce this we won't be able to fix it.

comment:8 Changed 2 years ago by janousek.jan

It´s not a bug of jQuery, or jQuery UI. There is a bug in some versions of IE10 (for example IE 10.0.9200.16384). This will be fixed by Microsoft. There is problem with pageX and pageY property of event.

comment:9 Changed 2 years ago by scott.gonzalez

  • Status changed from new to closed
  • Resolution set to wontfix

comment:10 Changed 2 years ago by dmethvin

Confirmed, this is a bug in the IE10 RTM but they are planning to have a hotfix out this month. It's not possible to detect the incorrect values from jQuery or jQuery UI in any case. See  http://bugs.jquery.com/ticket/12343 .

comment:11 Changed 2 years ago by mazzoo

Thank you for your help !

Fantastic support.

Note: See TracTickets for help on using tickets.