Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10030 closed bug (duplicate)

Memory leak using JQueryUI-1.10.3 in IE 8

Reported by: Vijay Owned by:
Priority: minor Milestone: none
Component: [meta] ui.build Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

i developed application which loaded/displays web pages into a webbrowser control. when the page is loaded/displayed in the application i observed a huge memory leaking in my application. After digging i understood memory raise is due to the usage of JqueryUI .To find out the root cause i modified my page to a very simple page like below.

<!DOCTYPE html> <html>

<head>

<title>Sample test page</title>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

<meta http-equiv="x-ua-compatible" content="IE=8">

<script type="text/javascript" src="myscript/jquery-1.9.1.js"></script>

<script type="text/javascript" src="myscript/jquery-ui-1.10.3.js"></script> </head>

<body> <a href="C:\TestPages\sampleleakpage.htm">Click Me </a> </body>

</html>

i am not loading any UI control in page. i just added the script tag to page. every time page is loaded there is raise of 2MB memory leak, the memory is never getting down even the application is sitting in ldle for hours . i used sIEve.exe tool to identify the raise in the memory. i suspect this is a memory leak and require your support/help to solve this problem.

i am not sure what needs to be done to bring the memory down,i am assume there might be some script that can written in the unload page event to dispose the objects/events to resolve this memory leak issue.

highly appreciate your help, Thanks

Change History (11)

comment:1 Changed 6 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4188.

comment:2 Changed 6 years ago by Vijay

how http://bugs.jqueryui.com/ticket/4188 solve the problem ?

comment:3 Changed 6 years ago by Scott González

It doesn't. We haven't been able to track down the problem.

comment:4 in reply to:  3 Changed 6 years ago by Vijay

Replying to scott.gonzalez:

It doesn't. We haven't been able to track down the problem.

Hi Scott, do you mean say it is a know memory leak issue and will be fixed in later version ?

comment:5 Changed 6 years ago by Vijay

Hi Scott, do you mean say it is a know memory leak issue and will be fixed in later version ?

comment:6 Changed 6 years ago by Scott González

No, I mean that it's a known memory leak that won't be fixed unless someone can figure out what's leaking.

comment:7 Changed 6 years ago by Vijay

To clarify, you are confirming there IS a known memory leak when using JQueryUI-1.10.3 in IE 8, and at present nobody has been able to find the root cause or provide a fix for the leak when using this library.

We observe the size of the leak to be in the order of 2MB (change this to be the correct value, as appropriate). Can you confirm this size of leak is known when using the full library, so we can isolate that part and help diagnose the issue within our solution.

Thanks for your support.

comment:8 Changed 6 years ago by Vijay

Hi Scott,

As stated previously, we observe the size of the leak to be around 1.5 to 2 MB. Can you please confirm that this size of leak is known when using the full library?

Thanks for your support.

comment:9 Changed 6 years ago by Scott González

I don't know.

comment:10 Changed 6 years ago by df515107

Hi Scott, you said ‘I mean that it's a known memory leak that won't be fixed unless someone can figure out what's leaking’. We will continue investigating JQuery-UI version 1.10.3 and Microsoft Internet Explorer 8 web browser control, but please tell us what you know about the known memory leak and so that we can help to further characterise the issue.

Thanks, Donald (I work with Vijay)

comment:11 Changed 6 years ago by tj.vantoll

Donald,

We really don't know. Here are some open tickets that discuss potential leaks.

Note: See TracTickets for help on using tickets.