Opened 6 years ago

Closed 6 years ago

#10069 closed bug (duplicate)

wrong calculation of dialog content width and height with css theme "start"

Reported by: nico Owned by: nico
Priority: minor Milestone: none
Component: ui.resizable Version: 1.10.4
Keywords: Cc:
Blocked by: Blocking:

Description

It seems that problem occurs with theme "start" because I could not make a jsFiddle showing it. My dialog is very simple, At the click of the user I load content from the server.

HTML code :

<div id="dialog"></div>
<div>
    <li>
        <a href="configuration.do" class="dialogify" title="Configuration de l'application">Configuration</a>
    </li>
</div>

JS code :

    $("#dialog").dialog({
        autoOpen: false
    });
    $(".dialogify").on("click", function(e) {
        var title = this.title;
        e.preventDefault();
        $("#dialog").html("");
        $("#dialog").dialog("option", "title", "Loading...").dialog("open");
        $("#dialog").load(this.href, function() {
            $(this).dialog("option", "title", title);
        });
    });

The issue is that each time I resize the dialog, the content of the dialog loses space. The workaround I found is to set the following CSS :

#dialog {
    padding: 3.5px;
}

Then the content of the dialog is correctly resized.

Change History (3)

comment:1 Changed 6 years ago by Scott González

Owner: set to nico
Status: newpending

I could not make a jsFiddle showing it

We'll need a reduced test case showing the problem. If you can't recreate the problem in jsfiddle, what makes you think we can?

comment:2 Changed 6 years ago by nico

Status: pendingnew

Ok, close the ticket then, it was just in order to help.

Go to http://jqueryui.com/themeroller/, choose theme "start", open the dialog box and resize it. You will see that each time you resize the dialog box, the size of the content is reduced.

comment:3 Changed 6 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #9832.
This isn't tied to the start theme, using the default theme on ThemeRoller also shows the problem.

Note: See TracTickets for help on using tickets.