Opened 5 years ago

Closed 5 years ago

#10230 closed bug (duplicate)

Draggable improperly blurs in certain cases

Reported by: dcherman1 Owned by:
Priority: minor Milestone: none
Component: ui.draggable Version: 1.11.0
Keywords: Cc:
Blocked by: Blocking:

Description

JSFiddle: http://jsfiddle.net/JGw96/

In _mouseCapture occurs in draggable, the first thing is does is blur the activeElement if it's not the body, then it's checking to see whether or not the mousedown event should have been handled in the first place.

In my case, I have a handle defined, so _mouseCapture will end up returning false since it shouldn't handle that specific event. I think that in those cases, the activeElement should not have been blurred.

Change History (1)

comment:1 Changed 5 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #10527.
That's true, and we fixed this in #10527

Note: See TracTickets for help on using tickets.