Opened 5 years ago

Closed 5 years ago

#10528 closed feature (invalid)

bug: Datepicker: If numberOfMonths is > 1, a width is set on the element

Reported by: zeek Owned by: zeek
Priority: minor Milestone: none
Component: ui.datepicker Version: git (not yet released)
Keywords: Cc:
Blocked by: Blocking:

Description

Browser: irrelevant

OS: irrelevant

jQuery UI Version: git, possibly all older ones

Steps to reproduce:

  1. create a datepicker
  2. set numberOfMonths > 1

Expected:

if numberOfMonths == 2 -> .ui-datepicker-multi-2 class should be used to set the width

What happens:

the datepicker sets a width on the element itself, which makes it impossible to overwrite without !important

What to change:

Line 814 - 816 of datepicker.js should be removed https://github.com/jquery/jquery-ui/blob/master/ui/datepicker.js#L815

CSS classes ui-datepicker-multi-2, ui-datepicker-multi-3 and ui-datepicker-multi-4 should be added or changed to set the appropriate width

Thx

Change History (2)

comment:1 Changed 5 years ago by Scott González

Owner: set to zeek
Status: newpending

Sorry, but you haven't actually described a bug. Please show how this is causing problems.

Side note: Don't set the type as feature and then put "bug" in your title.

comment:2 Changed 5 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.