Opened 5 years ago

Closed 2 years ago

#10574 closed bug (fixed)

Selectmenu vertical alignment is incorrect

Reported by: Alexander Schmitz Owned by:
Priority: minor Milestone: 1.12.0
Component: ui.selectmenu Version: 1.11.1
Keywords: Cc:
Blocked by: Blocking:

Description

The selectmenu button is misaligned with other form controls by default. The selectmenu button is also 3px taller then the button widget. Native buttons and selects are the same height and I believe the widgets should be too for both consistency with native and visual consistency.

http://jsbin.com/desupu/1

This is fixed by the by the button re-write so there is probably no need to worry about this since that will land very soon.

Change History (3)

comment:1 Changed 5 years ago by Jörn Zaefferer

Status: newopen

comment:2 Changed 2 years ago by Ben RUBSON

Hi,

Same issue, which leads to a vertically miss-aligned selectmenu in table.

I can reproduce it with Safari (10.1), with both jQuery 1.11.4 and 1.12.1.

Following screenshot show that the selectmenu is over the bottom table border (with padding = margin = 0, vertical-align = bottom).

Any plan to fix this ?

Many thx !

Ben

https://s14.postimg.org/jc66brpa9/Screen_Shot_2017-04-30_at_17.09.18.png

comment:3 Changed 2 years ago by Scott González

Milestone: none1.12.0
Resolution: fixed
Status: openclosed

Ben, that issue is completely different form what this ticket is talking about.

This has been fixed since 1.12.0 with the button rewrite.

Note: See TracTickets for help on using tickets.