Opened 5 years ago

Closed 4 years ago

#10584 closed bug (invalid)

Jquery range slider handle not correctly working in IE9 and IE10

Reported by: sumanegi Owned by: sumanegi
Priority: minor Milestone: none
Component: ui.slider Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have custom code for a jQuery range slider. I am facing an issue in specific to IE9 and IE10. NOTE: That in IE8 it works fine.

This slider has a tool tip on hover over each handle. When both handles come close to each other, the right handle is not movable anymore. I noticed that in IE9/10,that clicking on the right handle triggers focus on left handle which makes left handle movable only.

Issue found in IE9/10/windows7(work find in chrome Firefox 32)

Demo: http://jsfiddle.net/snegi/j70k34vy/

Example to reproduce: suppose left handle at 30%, right handle 31%. now if you click on right handle then left handle also get focus and make right handle unmovable.

Change History (2)

comment:1 Changed 5 years ago by tj.vantoll

Owner: set to sumanegi
Status: newpending

Hi sumanegi,

Thanks for taking the time to contribute to jQuery UI. I see the behavior you're describing, but it's difficult to tell exactly what's going on here because there's so much custom code. Can you please reduce this example to the minimum amount of code needed to show the bug? Also, please update the code to use the latest version of jQuery UI.

Thanks.

comment:2 Changed 4 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.