Opened 5 years ago

Closed 5 years ago

#10592 closed bug (duplicate)

Modal, Draggable Dialog does not submit if field with focus is offscreen

Reported by: swampyuk Owned by: swampyuk
Priority: minor Milestone: none
Component: ui.dialog Version: 1.11.1
Keywords: Cc:
Blocked by: Blocking:

Description

Issue occurs in IE11. Seems to occur in IE10/IE9 document mode as well.

Reproduceable here: http://jsfiddle.net/1n5tv3dt/13/

Steps to reproduce:

  • Click ‘Run’
  • Click on the ‘Click me’ button. A dialog will appear
  • Put text in the first field.
  • Make the window small enough scroll bars appear
  • Scroll the first field off the screen
  • Click the ‘okbutton’ or ‘closemenow’ button
  • The dialog does not generate an alert – it scrolls to the top.

Workaround: Making the dialog non-modal or non-draggable fixes the issue.

Change History (3)

comment:1 Changed 5 years ago by tj.vantoll

Owner: set to swampyuk
Status: newpending

Hi swampyuk,

This issue appears to have already been fixed in master. See http://jsfiddle.net/tj_vantoll/1n5tv3dt/14/. Can you confirm?

Thanks.

comment:2 Changed 5 years ago by swampyuk

Status: pendingnew

I can confirm it's fixed in master!

Many thanks for the fast response. Greatly appreciated.

comment:3 Changed 5 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #10527.

Note: See TracTickets for help on using tickets.