Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10629 closed bug (duplicate)

Datepicker memory leak (_disabledInputs)

Reported by: olejorgenb Owned by:
Priority: minor Milestone: none
Component: ui.core Version: 1.11.1
Keywords: Cc:
Blocked by: Blocking:

Description

This list is never cleared - so if you disable a datepicker in a single-page-app, the datepicker dom element will leak. (I don't have time to create a nice test case for this right now) Leak observed in version 1.10.2, but looking at the code in 1.11.1 it seems to still be a problem there

Change History (3)

comment:1 Changed 6 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #9555.

comment:2 Changed 6 years ago by olejorgenb

I don't see how it's clear that #9555 is the same issue. I found that ticket before creating this one, but didn't see a connection besides the words "memory" and "leak". If the _disabledInput mechanism actually is the cause of the leak in #9555 it might be an idea to update the ticker with that information? (which seems unlikely since that ticker talks about the leak happening just by including jquery ui)

Last edited 6 years ago by olejorgenb (previous) (diff)

comment:3 Changed 6 years ago by Scott González

As the other ticket says, unless someone else is going to provide a PR, it doesn't matter. We're already very far into the rewrite of datepicker.

Note: See TracTickets for help on using tickets.