Opened 5 years ago

Closed 5 years ago

#10702 closed bug (duplicate)

Tabs thinking my content is remote

Reported by: JulienNauroy Owned by:
Priority: minor Milestone: none
Component: ui.tabs Version: 1.11.2
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

Since JQueryUI 1.9 I think, Tabs behave as if my content is remote. I'm using a <base> tag in my HTML code which points to the root of the website, while the page I'm using tabs on is within a subfolder (say http://website/admin/)

I'm referring to tabs with a simple href="#tab1" in my list items and provide the proper <divs>.

My problem seems to come from the _isLocal method which checks if the anchorURL and locationURL are the same. Technically, JQueryUI is completely right since providing the <base> tag makes my link point to http://mysite/#tab1 and not http://mysite/admin/#tab1 However, I think it would be better if JQueryUI could handle such case by considering I'm referring to my current page and not a remote one. It doesn't seem to go against HTML standards to me since it's not really an anchor.

Thus, the _isLocal function could be changed to only check if the Url starts with a # symbol (maybe something else would break in this case?). Another possibility could be to check if divs with the same name are present within the tab's container div.

What do you think?

Change History (2)

comment:1 Changed 5 years ago by JulienNauroy

Here's an example of the problem. See how <base> changes the behavior of the demo content : http://jsfiddle.net/84wxdp4z/

comment:2 Changed 5 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #7822.

Note: See TracTickets for help on using tickets.