Opened 5 years ago

Closed 5 years ago

#10925 closed feature (duplicate)

Need a way to lock tooltip up / copy text

Reported by: tlhackque Owned by:
Priority: minor Milestone: none
Component: ui.tooltip Version: 1.11.2
Keywords: Cc:
Blocked by: Blocking:

Description

I am using tooltip to display supplementary information, for example in a hardware transaction report, the tooltip may provide a decode of the serial number.

Tooltips work well for this; the detail is available when you need it with zero clicks, but the screen isn't cluttered.

Except for one thing.

I would like to be able to offer the ability to copy detail to the clipboard. A context menu click would do. Or if I could lock the tooltip open by clicking on the primary element... which would allow traditional copy and paste.

I tried to make this work - with and without ZeroClipboard. The interactions defeated me.

I'm thinking of a simple API that could be toggled 'onclick' of the primary element, which would open the tooltip & suspend the mouseout close in the first instance, and in the second would resume the mouseout montioring. That could be triggered by <esc>, or by the mouse moving off the *tooltip* (e.g., after copy).

Anything along those lines would make me happy...

Thanks.

Change History (1)

comment:1 Changed 5 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #8782.

Note: See TracTickets for help on using tickets.