Opened 7 years ago

Closed 6 years ago

#11053 closed feature (fixed)

Investigate performance of querying text direction per widget

Reported by: Scott González Owned by:
Priority: minor Milestone: git
Component: [meta] ui.dev Version: 1.11.2
Keywords: Cc:
Blocked by: Blocking:

Description

We want to support RTL configuration per widget, so we should investigate the performance cost of determining the direction on creation. We should check the performance of using .closest( "[dir]" ) and manually walking up the DOM using parentNode and checking for a non-empty dir property.

Change History (2)

comment:1 Changed 6 years ago by Scott González

#14477 is a duplicate of this ticket.

comment:2 Changed 6 years ago by Scott González

Milestone: nonegit
Resolution: fixed
Status: newclosed

We don't need to query the DOM like this, we can just use .css( "direction" ).

Note: See TracTickets for help on using tickets.