Opened 5 years ago

Closed 5 years ago

#11193 closed bug (duplicate)

Auotocomplete menu requires two touches on iOS Safari

Reported by: deains Owned by:
Priority: minor Milestone: none
Component: ui.autocomplete Version: 1.11.0
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery version: any (tested in 1.10, 2.1) jQuery UI version: 1.11.0 and above (works on 1.10.4, tested up to 1.11.3)

To replicate this bug I used the demo HTML available here: http://jqueryui.com/resources/demos/autocomplete/default.html, changing lib versions as necessary.

When using Safari on an iOS device (iOS 8.1 - tested on iPhone, iPad), items in the autocomplete menu require two touches to activate. On the first touch, the item gets ui-state-focus and the associated style. On the second touch, the click behaviour is observed and the autocomplete goes through.

On 1.10.4, the ui-state-focus step is skipped, so only one touch is needed, same as on a conventional browser.

An added curiosity is that when the demo page is loaded inside an iframe, the bug does not occur and the 1.10.4 behaviour happens instead. So because the jQuery UI website uses an iframe the bug doesn't occur on the main demo page (http://jqueryui.com/autocomplete/).

Change History (1)

comment:1 Changed 5 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #10544.

Note: See TracTickets for help on using tickets.