Opened 7 years ago

Closed 7 years ago

#11227 closed bug (duplicate)

ui.sortable connectWith draggable draggable.helper is added, not draggable.item

Reported by: stef Owned by:
Priority: minor Milestone: none
Component: ui.sortable Version: 1.11.3
Keywords: Cc:
Blocked by: Blocking:

Description

When I drag an item from a draggable list (a tr from a table) to a sortable list (a tbody from a table), in the receive event, ui.item is the dragged item (the original tr from draggable table), but in the update event, ui.item is the helper that has been created for the dragging action.

See https://jsfiddle.net/stefuniv/gmvjmgLh/30/ for example.

In my application, the problem was exist since jqueryui 1.11.2. No problem with 1.11.1 version. Tested with firefox 31.

Change History (1)

comment:1 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #4303.

Note: See TracTickets for help on using tickets.