Opened 5 years ago

Closed 5 years ago

#11339 closed bug (duplicate)

sortable('refresh') does not update behavior of sortable

Reported by: iamsalnikov Owned by:
Priority: minor Milestone: none
Component: ui.sortable Version: 1.11.3
Keywords: Cc:
Blocked by: Blocking:

Description

Recently we have a small discussion with angular-ui/ui-sortable. It is wrapper under ui.sortable for angularjs. There is bug, where we try to set dynamically locked items.

Then we reproduce this bug on pure jquery.ui: http://codepen.io/anon/pen/ByPGPm

As you can see, if we create a sortable list of an items and after one second add to one of item ".not-sortable" class, and after call on sortable element method refresh - behavior does not change.

Discussion on github with angular-ui/ui-sortable: https://github.com/angular-ui/ui-sortable/issues/341

Change History (1)

comment:1 Changed 5 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5781.

Note: See TracTickets for help on using tickets.