Opened 4 years ago

Closed 4 years ago

#11616 closed bug (worksforme)

right-clicks on the tab and selects to open in new window/tab results in only tab content loaded

Reported by: phuongu Owned by:
Priority: minor Milestone: none
Component: ui.tabs Version: 1.11.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have made an upgrade of JQuery UI from 1.8 to 1.11 in my web applicaiton, which causes a change in behaviour of the tab, where right-clicks on the tab and selects to open in new window/tab results in only tab content loaded. This means that the Url associated with the tab itself is that of the partial that's loaded via ajax rather than the hash associated with the tab.

To my knowledge there has been a changed introduced in jQueryUI v1.9 that is relevant to the issue and also my be relevant to this ticket Ticket #9363

A hint for a fix or workaound would be appreciated.

Change History (2)

comment:1 Changed 4 years ago by phuongu

I have made an upgrade of JQuery UI from 1.8 to 1.11 in my web applicaiton, which causes a change in behaviour of the tab, where right-clicks on the tab and selects to open in new window/tab results in only tab content loaded. This means that the Url associated with the tab itself is that of the partial that's loaded via ajax rather than the hash associated with the tab.

The issue is that the new page will straight up display the HTML of the ajax response with no CSS styling, JavaScript, or anything.

To my knowledge there has been a change introduced in jQueryUI v1.9 that is relevant to the issue and also might be relevant to Ticket #9363

A hint for a fix or workaound would be appreciated.

comment:2 Changed 4 years ago by Scott González

Resolution: worksforme
Status: newclosed

That's definitely not happening for me on http://view.jqueryui.com/master/demos/tabs/default.html.

Please provide a reduced test case as requested in the red box if you continue to have problems. We can re-open the ticket if it's reproducible.

Note: See TracTickets for help on using tickets.