Opened 5 years ago

Closed 5 years ago

#12262 closed bug (duplicate)

Selectmenu calling refresh with no options throws expection

Reported by: jeffpizza Owned by:
Priority: minor Milestone: none
Component: ui.selectmenu Version: 1.11.4
Keywords: Cc:
Blocked by: Blocking:

Description

If you create a selectmenu with no options and call refresh, you get an exception.

http://jsfiddle.net/zz1z7ov6/1/

Stack Trace:

Uncaught TypeError: Cannot read property 'eq' of undefined
$.widget._getSelectedItem @ jquery-ui.js:12513
(anonymous function) @ jquery-ui.js:415
$.widget.refresh @ jquery-ui.js:12362
(anonymous function) @ jquery-ui.js:415
(anonymous function) @ jquery-ui.js:508
jQuery.extend.each @ jquery-1.11.0.js:384
jQuery.fn.jQuery.each @ jquery-1.11.0.js:137
$.widget.bridge.$.fn.(anonymous function) @ jquery-ui.js:494(
anonymous function) @ (index):31
jQuery.Callbacks.fire @ jquery-1.11.0.js:3099
jQuery.Callbacks.self.fireWith @ jquery-1.11.0.js:3211
jQuery.extend.ready @ jquery-1.11.0.js:3423
completed @ jquery-1.11.0.js:3453

Might be related to this previous bug? http://bugs.jqueryui.com/ticket/10662

Change History (1)

comment:1 Changed 5 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #10662.
Not related, it's exactly that bug. See the milestone on the ticket.

Note: See TracTickets for help on using tickets.