#12472 closed bug (fixed)

Draggable handle does not allow unrelated elements to blur

Reported by: Atletismo343 Owned by:
Priority: minor Milestone: 1.12.0
Component: ui.draggable Version: 1.11.4
Keywords: Cc:
Blocked by: Blocking:

Description

If a draggable container has an input field with focus, clicking on another draggable item does not cause the first input field to blur. This is an issue with functions like auto-save that rely on handling the blur event on input fields.

See this jsbin for example: http://jsbin.com/gayisa/1/

I would expect clicking on another draggable item to blur the existing element. The root cause appears to be related to this PR: https://github.com/jquery/jquery-ui/pull/1314

Change History (3)

comment:1 Changed 22 months ago by scottgonzalez

  • Status changed from new to open

Discussion and potential fix in https://github.com/jquery/jquery-ui/pull/1548.

comment:2 Changed 13 months ago by scottgonzalez

See also #14905.

comment:3 Changed 13 months ago by scottgonzalez

  • Milestone changed from none to 1.12.0
  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.