Opened 4 years ago

Closed 4 years ago

#13278 closed bug (duplicate)

Scaled Draggable helperProportions are not "scaled"

Reported by: rawk Owned by:
Priority: minor Milestone: none
Component: ui.draggable Version: 1.11.4
Keywords: Cc:
Blocked by: Blocking:

Description

A scaled element (modified with css: transform: scale(0.5, 0.5) for example) would not have the scaled proportions stored in the helperProportions property.

For example: a 400px by 400px div scaled by (0.5, 0.5) should have a 200px height and width stored in the helperProportions property, however, it has the full proportions.

This causes problems when interacting with droppables that have the tolerance parameter set to "touch" since they would "touch" even if they're not visually touching, and there may be many other problems related to scaled elements, but this one was the one that I faced.

Change History (5)

comment:1 Changed 4 years ago by rawk

I will be submitting a pull request shortly with a possible fix

comment:2 Changed 4 years ago by rawk

Last edited 4 years ago by rawk (previous) (diff)

comment:3 Changed 4 years ago by rawk

Pull request submitted

comment:4 Changed 4 years ago by rawk

It seems this bug was reported in jQuery several years ago. They decided not to fix it though: http://bugs.jquery.com/ticket/11114

comment:5 Changed 4 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #6844.

Note: See TracTickets for help on using tickets.