Opened 5 years ago

Closed 5 years ago

#14242 closed bug (duplicate)

ui.a11y slider & aria behaviour

Reported by: disic Owned by:
Priority: minor Milestone: none
Component: ui.slider Version: 1.11.3
Keywords: Cc:
Blocked by: Blocking:

Description

Issue : According to http://www.w3.org/TR/wai-aria-practices/#slider If you focus the handle, the element shoud get attribut role=”slider”, aria-valuemax=”...” aria-valuemin="...". And when the user change the value, these attribut shoud change aria-valuenow="..." aria-valuetext="...", exemple aria-valuenow="7" aria-valuetext="$7"

Feature : Add the possibilty to create custom attribut on the handle. For instance if I want to add attribut aria-labelledby, there is no option to easily add it.

Change History (1)

comment:1 Changed 5 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4739.

Note: See TracTickets for help on using tickets.