Opened 6 years ago

Closed 6 years ago

#14738 closed bug (duplicate)

Datepicker flashes incorrect month when selecting a date range

Reported by: rchott Owned by:
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.11.4
Keywords: Cc:
Blocked by: Blocking:

Description

When using two datepickers to select a date range, Changing a date one datepicker will cause it to flicker and briefly show the month currently selected by the other datepicker just before it fades out.

This issue can even be seen on the sample here: https://jqueryui.com/datepicker/#date-range

To re-create on the sample page:

  1. Select the current date in the datepicker labeled "from". This indicates the start-of-range (I used October 26, 2015)
  1. Select a date from a different month in the end-of-range datepicker labeled "to" (I used November 26, 2015)
  1. Now go back and change the start-of-range ("from") datepicker to another date in the same month (October 25)

...As I make the selection in the "from" datepicker in step 3, It briefly switches to November (or whatever month the end-of-range is currently set to) just before it closes.

All functionality works fine, however this display issue is having a negative effect our users' experience.

Change History (1)

comment:1 Changed 6 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #8907.

Note: See TracTickets for help on using tickets.