Opened 6 years ago

Closed 5 years ago

#14822 closed bug (duplicate)

Draggable helper position gradually offsets on entering/leaving sortables when a margin is applied on the draggable

Reported by: ndm Owned by:
Priority: minor Milestone: none
Component: ui.sortable Version: 1.11.4
Keywords: Cc:
Blocked by: Blocking:

Description

The title summarizes the problem. When a margin is being applied to a draggable, the helper is being gradually offset when entering/leaving sortables, to be exact, it will slowly shift to the top-left.

Working example: http://jsfiddle.net/16ahnfhk/
Screencast: http://i.imgur.com/tMgHl5w.gif

Just grab one of the draggables, and drag it back and forth in/out of the sortables. When removing the margin, you should see that problem doesn't occur anymore.

ps. I had already reported this yesterday (#14805), but it seems that it has been deleted, accidentially I assume.

Change History (4)

comment:1 Changed 6 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #14806.
We kept the one that you had commented on.

comment:2 Changed 6 years ago by ndm

@scott.gonzalez But other than the #14806 duplicates caused by the Trac glitch, #14805, just like this ticket, describes a different cause for a problem that is only kind of similar. So my question would be whether you are sure that is really a cause-wise duplicate?

The result, ie the helper position being incorrect is similar, but still different, just like the ways to trigger the problem. Are you sure that both symptoms share the same internal cause, ie will fixing one, fix the other too? I'm not familiar with the jQuery UI source, I just have my doubts from looking at all the other similar helper offset bugs.

comment:3 Changed 6 years ago by Scott González

Resolution: duplicate
Status: closedreopened

Oh, sorry. I the titles were similar enough that I didn't even notice they were different tickets when I was cleaning up the duplicates.

comment:4 Changed 5 years ago by Scott González

Resolution: duplicate
Status: reopenedclosed

Duplicate of #11086.

Note: See TracTickets for help on using tickets.