Opened 6 years ago

Closed 6 years ago

#14899 closed bug (fixed)

Buttonset fails accessibility testing.

Reported by: Marvin Herbold Owned by:
Priority: major Milestone: none
Component: ui.core Version: 1.11.3
Keywords: buttonset accessibilty 508 Cc:
Blocked by: Blocking:

Description

This is using jquery 1.11.4 -

This is with regards to keyboard navigation and buttonsets. To be clear, keyboard navigation works just fine. The issue is with the UI display of buttonsets.

When you have a buttonset checkbox that is in the checked state, and the keyboard focus falls on it, you have no way to tell. So if you have a series of checkboxes that is part of a buttonset, and they are all in the checked state, you are going to have a bear of a time trying to navigate through that buttonset because you can't see which checkbox has focus.

There is a similar issue with radio buttons - if you have a buttonset of radio buttons and it has focus you just can't tell. This caused our website to fail 508 certification testing. Every other widget that we use passed except for this one.

Change History (1)

comment:1 Changed 6 years ago by Alexander Schmitz

Resolution: fixed
Status: newclosed

This was fixed in the new controlgroup widget which is in 1.12 so im going to close this.

Note: See TracTickets for help on using tickets.