Opened 3 years ago

Closed 3 years ago

#14906 closed bug (duplicate)

Offset issues with jQuery Draggable into an iFrame based Sortable

Reported by: Kevin H. Kamel Owned by:
Priority: minor Milestone: none
Component: ui.draggable Version: 1.11.3
Keywords: Cc:
Blocked by: Blocking:

Description

I'm having quite a bit of trouble resolving problems with offsets related to draggable elements being dropped into a sortable area within an iFrame.

I've created a demo project on github, as jsfiddle does not easily allow you to use same-domain iframes. It's located here: http://kamelkev.github.io/jquery-ui-sortable-iframe/

Make sure to keep your window fairly narrow, as otherwise it's very difficult to drop the elements into the iFrame at all. It should be pretty obvious that you cannot drag the item and drop it in the designated place, instead you must drag about 350 pixels to the right of the leftmost border, after which the sortable will accept the draggable.

I've tried quite a few things here already, but thus far I have been unable to narrow down the problem. I'm not even entirely sure I understand the source of the problem, just knowing that would allow me to possibly write a plugin that could correct this issue.

I do have a good reason for needing to use the iFrame (I'm attempting to create a drag/drop email builder tool, and need isolate the content from external styling). I initially built this out using droppables which have a similar offset issue, I was able to solve those problems without much trouble, unfortunately this issue appears much much harder.

It's not clear to me if this is not a supported feature. In the past I've seen tickets closed indicating that cross-window dragging was not a supported feature, but in recent years I've seen that line slowly blur. I figure since we now have the updated iframeFix feature, maybe this is supported too. Apologies if not.

Change History (2)

comment:1 Changed 3 years ago by Kevin H. Kamel

I don't know how to tag tickets for this queue. If someone could review the tagging I'd appreciate it.

comment:2 Changed 3 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #7925.

Note: See TracTickets for help on using tickets.