Opened 3 years ago

Closed 3 years ago

#14937 closed bug (duplicate)

Jquery UI dialog vs datepicker

Reported by: Eugene Maslovich Owned by:
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.11.4
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Ryan J Ollos)

Hi. I have the following code http://pastebin.com/raw/CZd3FsPm. We are opening ui dialog with one input in it and attaching a datepicker. It works like charm except in IE11 where it doesn't close on date selection. When a user clicks any date the datepicker hides itself and then immediately restores. I've found the problem in these lines of code of jquery ui:

                if ( !this.document.data( "ui-dialog-overlays" ) ) {

                        // Prevent use of anchors and inputs
                        // Using _on() for an event handler shared across many instances is
                        // safe because the dialogs stack and must be closed in reverse order
                        this._on( this.document, {
                                focusin: function( event ) {
                                        if ( isOpening ) {
                                                return;
                                        }

                                        if ( !this._allowInteraction( event ) ) {
                                                event.preventDefault();
                                                this._trackingInstances()[ 0 ]._focusTabbable();
                                        }
                                }
                        });
                }

_focusTabbable focuses back on input and datepicker reopens.

Change History (2)

comment:1 Changed 3 years ago by Ryan J Ollos

Description: modified (diff)

comment:2 Changed 3 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #9125.

Note: See TracTickets for help on using tickets.